Issues with American Express payments in EU
Incident Report for Klarna
Resolved
This incident has been resolved.
Posted May 04, 2020 - 15:06 CEST
Investigating
There is currently a problem affecting some users in the EU who try to pay with American Express credit cards. Transactions may fail or may be executed twice. We are investigating this to resolve it as quickly as possible and apologize for any inconvenience caused in the meantime.
Posted May 04, 2020 - 11:28 CEST