Klarna App degradation

Incident Report for Klarna

Resolved

This incident has been resolved.
Posted Aug 08, 2022 - 16:00 CEST

Update

The service is now back to normal. Thank you for your patience.
Posted Aug 08, 2022 - 16:00 CEST

Update

We have identified the issue and expect to be fully operational within 30 minutea
Posted Aug 08, 2022 - 15:52 CEST

Investigating

We are currently experiencing issues with visualising orders in Klarna App in Europe. We are working to restore the service as soon as possible. Thank you for your patience.
Posted Aug 08, 2022 - 15:49 CEST
This incident affected: Klarna App (Europe).