Support system degradation with email
Incident Report for Klarna
Resolved
This incident has been resolved.
Posted Sep 14, 2022 - 07:38 CEST
Investigating
We are currently experiencing issues with reaching support via email. We have identified the cause and are working to restore the service as soon as possible.
Chat and phone support are currently operating normally.
Posted Sep 14, 2022 - 07:01 CEST
This incident affected: Support (Europe, North America, Asia Pacific).