Extra login modal for Finland
Incident Report for Klarna
Resolved
This incident has been resolved.
Posted May 06, 2024 - 15:41 CEST
Investigating
We are currently experiencing issues with an extra login modal presented to a part of our consumers in Finland. We are working to restore the service as soon as possible. Thank you for your patience.
Posted May 06, 2024 - 15:28 CEST