Paybright payment options are not available in Canada
Incident Report for Klarna
Resolved
This incident has been resolved by PayBright. We apologize for the inconvenience.
Posted Sep 01, 2021 - 18:06 CEST
Update
We are in contact with Paybright who continues to work on the issue. At this time we are seeing some traffic start to go through to Paybright.
We apologize for the inconvenience.
Posted Sep 01, 2021 - 17:36 CEST
Investigating
Do to a issue with Paybright, 3rd party vender, customers/merchants in Canada do not have an option of selecting Paybright as a payment option while checking out in Canada.
Posted Sep 01, 2021 - 16:59 CEST