Payment method Pay in Parts in the US has degradation since 01:10 a.m. CEST for less than 1% of the consumers using this payment method.
Incident Report for Klarna
Resolved
This incident has been resolved.
Posted Jul 20, 2021 - 01:30 CEST
Investigating
We are currently investigating this issue.
Posted Jul 20, 2021 - 01:15 CEST
This incident affected: Klarna Payments (KP).