Degradation of Klarna Payments made through PayBright
Incident Report for Klarna
Resolved
We've confirmed with PayBright that the issue has been resolved.
Posted Jul 10, 2020 - 18:12 CEST
Update
We appreciate your patience as we continue to work with PayBright on a solution. We anticipate providing a further update to this problem no later than July 10.
Posted Jul 03, 2020 - 18:04 CEST
Update
We are continuing to work with PayBright to resolve this problem.
Posted Jun 30, 2020 - 14:03 CEST
Update
We are continuing to work on a fix for the issue with PayBright.
We will share our next update at 19:00CET. We thank you for your patience and apologize for the inconvenience caused.
Posted Jun 29, 2020 - 11:26 CEST
Identified
PayBright have identified the root cause and they are currently looking into a fix for the issue.
Posted Jun 26, 2020 - 17:22 CEST
Investigating
We are currently experiencing degradation for purchases made through PayBright. We are working together with PayBright to solve the issue as soon as possible.
Posted Jun 26, 2020 - 17:05 CEST
This incident affected: Klarna Payments (KP).