Billpay phonelines are partially down
Incident Report for Klarna
Resolved
Our engineers have resolved this problem and normal service is resumed. We thank you for your patience and apologise for the inconvenience caused. If you encounter any further trouble in relation to phone calls to Billpay, please reach out to your technical account manager for further assistance.
Posted Feb 28, 2020 - 09:33 CET
Investigating
Merchants and Customers in Switzerland are currently experiencing difficulties to reach BillPay via phone lines. Our engineers are investigating the issue and we apologise for the inconvenience caused. We will provide further updates as soon as possible.
Posted Feb 27, 2020 - 15:27 CET
This incident affected: BillPay.