Klarna App degradation

Incident Report for Klarna

Resolved

This incident has been resolved.
Posted Mar 11, 2025 - 22:00 CET

Investigating

We are currently experiencing issues with the Klarna App in EU. We are working to restore the service as soon as possible. Thank you for your patience.
Posted Mar 11, 2025 - 21:37 CET
This incident affected: Klarna App (Europe).