Merchant Portal unavailable in the EU
Incident Report for Klarna
Resolved
Following a period of monitoring, we have verified that the Merchant Portal is operational. We apologize for the inconvenience caused during this time.
Posted Apr 21, 2020 - 10:49 CEST
Monitoring
We have verified that it is now possible to login to the Merchant Portal again and we are continuing to monitor the service.
Posted Apr 21, 2020 - 10:20 CEST
Investigating
Merchants in the EU are currently unable to login to the Merchant Portal. We are investigating the issue and apologize for the inconvenience caused. We will provide further updates as soon as possible.
Posted Apr 21, 2020 - 09:47 CEST
This incident affected: Merchant Portal.