Consumers in Australia and New Zealand are not able to see their open invoices in the Klarna App
Incident Report for Klarna
Resolved
This incident has been resolved.
Posted Oct 07, 2021 - 11:32 CEST
Investigating
Consumers can't see their open invoices in the Klarna App.
Posted Oct 07, 2021 - 11:14 CEST
This incident affected: Klarna App.