Merchant Portal degradation
Incident Report for Klarna
Resolved
This incident has been resolved.
Posted May 23, 2023 - 16:16 CEST
Investigating
We are currently experiencing issues with the Merchant Portal. We are working to restore the service as soon as possible. Thank you for your patience.
Posted May 23, 2023 - 15:06 CEST
This incident affected: Merchant Operations (Europe).