Merchant settlement files delayed
Incident Report for Klarna
Resolved
This incident has been resolved.
Posted Nov 26, 2022 - 13:08 CET
Investigating
The settlement reports for US merchants have been delayed and we are working on getting the reports out as soon as possible. We are expecting the reports to be sent out during the day.
Posted Nov 26, 2022 - 11:59 CET
This incident affected: Merchant Operations (North America).