Card authorizations are failing in the US
Incident Report for Klarna
Resolved
This incident has been resolved.
Posted Sep 13, 2021 - 13:32 CEST
Investigating
We are currently investigating this issue.
Posted Sep 13, 2021 - 13:19 CEST