Problem with Sofort support telephony lines
Incident Report for Klarna
Resolved
The Sofort support telephone lines are now working properly. This incident has been resolved.
Posted Dec 16, 2019 - 09:04 CET
Update
We are still experiencing issues with some of the Sofort support phone lines. If you need to reach us you can call the main number (+49 89 20 20 8890) which has been restored to full functionality. We apologise for any inconvenience this incident may have caused.
Posted Dec 15, 2019 - 10:31 CET
Update
The ongoing problem with the Sofort support phone lines is still being investigated. If you need to reach us regarding Sofort issues please use email to contact us for best result until this has been resolved.
Posted Dec 14, 2019 - 15:34 CET
Investigating
Currently customers trying to reach our support phone lines for Sofort are likely to not be connected but instead just met with a busy tone. Our engineers are investigating the issue and we apologies for the inconvenience caused. We will provide further updates as soon as possible.
Posted Dec 14, 2019 - 15:08 CET
This incident affected: SOFORT.