~35% of Consumers in the EU are currently unable to create a one time card or signup for Klarna card
Incident Report for Klarna
Resolved
This incident is now resolved.
Posted May 26, 2021 - 08:58 CEST
Investigating
Consumers in the EU are not able to create a one-time card or signup for Klarna card due to issues on 3rd party.
Posted May 26, 2021 - 07:42 CEST
This incident affected: Klarna Card.