Klarna payments in the US were degraded
Incident Report for Klarna
Resolved
This incident has been resolved.
Posted Jul 08, 2021 - 12:04 CEST
Investigating
Klarna payments in the US were degraded between 08:53 and 09:48 CEST and have since recovered.
275 purchase attempts were impacted due to this incident.
We are monitoring the situation.
Posted Jul 08, 2021 - 11:20 CEST
This incident affected: Klarna Payments (KP).