Klarna Card degradation
Incident Report for Klarna
Resolved
This incident has been resolved.
Posted Jul 05, 2024 - 08:05 CEST
Identified
The issue has been identified as due to a third-party issue.
Posted Jul 05, 2024 - 07:52 CEST
Investigating
We are currently experiencing a degradation of Klarna Card in Germany, Sweden and the United Kingdom since 06:00 CEST. We are working to restore the service as soon as possible. Thank you for your patience.
Posted Jul 05, 2024 - 07:27 CEST
This incident affected: Klarna Card (Europe).