Customer Service degradation

Incident Report for Klarna

Resolved

The issues have been resolved. Thank you for your patience!
Some responses may still take longer than usual, but service levels will gradually return to normal.
Posted Jan 31, 2026 - 12:40 CET

Investigating

We are currently experiencing issues with Customer Service. We are working to restore the service as soon as possible. Please try again later. Thank you for your patience.
Posted Jan 31, 2026 - 09:42 CET
This incident affected: Customer Service (Europe, North America, Asia Pacific).