Direct bank transfer in the EU and US has degradation for ~60% of customers
Incident Report for Klarna
Resolved
This incident has been resolved.
Posted May 19, 2022 - 10:34 CEST
Monitoring
A fix has been implemented and we are monitoring the results.
Posted May 19, 2022 - 10:20 CEST
Investigating
We are currently experiencing a ~60% degradation of the Direct Bank Transfer payment method in the EU and US. We are working to restore the service as soon as possible. Thank you for your patience.
Posted May 19, 2022 - 10:18 CEST
This incident affected: Purchase API (Europe, North America).