Payment methods Pay in Parts and Slice It in the US has degradation since 08:30 a.m. CEST for 100% of new consumers using these payment methods.
Incident Report for Klarna
Resolved
This incident has been resolved.
Posted May 21, 2021 - 09:11 CEST
Investigating
The issue is impacting 100% of customers requiring card registration or CVV check on the stored cards
Posted May 21, 2021 - 08:30 CEST
This incident affected: Klarna Payments (KP).