New merchants are currently unable to complete the On-Boarding form from Klarna.com
Incident Report for Klarna
Resolved
This incident has been resolved.
Posted Nov 07, 2020 - 13:41 CET
Investigating
We are currently investigating the issue and apologize for any delay in getting your information.
Posted Nov 06, 2020 - 22:49 CET
This incident affected: Klarna Online.