Issues receiving emails sent to Klarna
Incident Report for Klarna
Resolved
This incident has been resolved. If you have sent us an email between 10:30 and 12:00 CET, we kindly request you send it again, as we might not have received the original email.
Posted Mar 14, 2023 - 12:11 CET
Investigating
We are currently experiencing issues with emails sent to Klarna. We are working to restore the service as soon as possible. Thank you for your patience.
Posted Mar 14, 2023 - 11:05 CET
This incident affected: Support (Europe, North America, Asia Pacific).