Degradation of Klarna Payments made through PayBright (Canada)
Incident Report for Klarna
Resolved
PayBright has confirmed that the issue has been resolved on their side and the services are now fully operational again.
Posted Nov 29, 2019 - 23:53 CET
Identified
We are currently experiencing degradation of our service where 10-15% of purchases made through PayBright are failing in Canada. We are working together with PayBright to solve the issue as soon as possible.
Posted Nov 29, 2019 - 23:11 CET
This incident affected: Klarna Payments (KP) Frontend and Klarna Payments (KP) Backend.