Disruption to Klarna Payments in the US
Incident Report for Klarna
Resolved
This issue has been resolved at 22:52 CET. We apologize for the inconvenience.
Posted Dec 18, 2020 - 23:10 CET
Investigating
We see degraded performance in Klarna Payments, affecting 4% of attempts. We are investigating the issue. We apologize for the inconvenience.
Posted Dec 18, 2020 - 22:23 CET
This incident affected: Klarna Payments (KP).