Customer support service degradation
Incident Report for Klarna
Resolved
This incident has been resolved.
Posted Mar 31, 2023 - 03:55 CEST
Investigating
We are currently experiencing issues with customer support services. We are working to restore the service as soon as possible. Thank you for your patience.
Posted Mar 31, 2023 - 02:34 CEST
This incident affected: Support (Europe, North America, Asia Pacific).