Klarna Payments degradation

Incident Report for Klarna

Resolved

This incident has been resolved.
Posted Aug 25, 2026 - 18:18 CEST

Investigating

During the period 16:12 - 16:40 CET we experienced a degradation to Klarna Payments. This issue has been resolved and all services are working as expected.
Posted Aug 25, 2026 - 18:17 CEST
This incident affected: Klarna Payments (Europe).