Experiencing issues with the US Merchant Portal
Incident Report for Klarna
Resolved
The issue has now been resolved and the US merchant portal is now available.
Posted 6 days ago. Aug 14, 2019 - 20:04 CEST
Investigating
We are currently experiencing issues with the Merchant Portal in the US. We are working to resolve it as fast as possible and will provide more information as soon as we know more.
Posted 6 days ago. Aug 14, 2019 - 19:51 CEST
This incident affected: Merchant Portal.