Customers is currently not able to perform payments using iDeal banks through Worldpay
Incident Report for Klarna
Resolved
This incident has been resolved.
Posted 25 days ago. Jun 27, 2019 - 09:17 CEST
Monitoring
Customers is currently not able to perform payments using iDeal banks through Worldpay, due to scheduled maintenance at Worldpay.
Posted 25 days ago. Jun 26, 2019 - 23:38 CEST