Minor disturbances in Klarna Checkout
Incident Report for Klarna
Resolved
We are back to normal operation.
Posted Jul 18, 2014 - 12:43 CEST
Investigating
We are experiencing disturbance in Klarna Checkout. Limited number of customers may be affected by the incident. We are working on it.
Posted Jul 18, 2014 - 11:21 CEST