We are no longer experiencing disturbances with the system.
Incident Report for Klarna
Resolved
The fix has been applied and all systems are working fine now.
Posted May 11, 2015 - 10:36 CEST
Identified
We are experiencing disturbances with the system, affecting primarily Klarna Online. The root cause is discovered and we are working on the fix.
Posted May 11, 2015 - 08:55 CEST