Klarna Card degradation
Incident Report for Klarna
Resolved
This incident has been resolved.
Posted Apr 17, 2024 - 07:10 CEST
Investigating
We are currently experiencing issues with Klarna Card in Europe . We are working to restore the service as soon as possible. Thank you for your patience.
Posted Apr 17, 2024 - 06:46 CEST
This incident affected: Klarna Card (Europe).