Intermittent access to the Merchant Portal
Incident Report for Klarna
Resolved
Access to the Merchant Portal has now been restored.
Posted Nov 23, 2020 - 19:25 CET
Investigating
Merchant Portal has been intermittently inaccessible for merchants in Europe. We are working to restore normal functionality and apologize for the inconvenience caused during this time.
Posted Nov 23, 2020 - 16:18 CET