Issues processing Visa transactions on the UK market
Incident Report for Klarna
Resolved
This incident has been resolved.
Posted Sep 29, 2021 - 12:02 CEST
Identified
We have identified the issue and are working on mitigations.
Posted Sep 29, 2021 - 11:54 CEST