Customer service disruption
Incident Report for Klarna
Resolved
This incident has been resolved.
Posted Nov 11, 2021 - 07:51 CET
Identified
We are currently experiencing an issue with some customer service systems. An issue has been identified, and we are working on a fix.
Posted Nov 11, 2021 - 07:11 CET