We are currently having sound quality issues with our telephony system in the EU
Incident Report for Klarna
Resolved
This incident has been resolved at this time.
Posted May 07, 2021 - 13:17 CEST
Investigating
Due to technical issues it can be difficult to communicate with consumer/merchant service by phone. We are working on solving this issue as soon as possible and apologize for any inconvenience caused in the meantime. We kindly request that you contact us through the chat instead.
Posted May 07, 2021 - 10:48 CEST