Payment method Slice It in the US has degradation since 11:10 AM
Incident Report for Klarna
Resolved
This incident has been resolved.
Posted Jun 16, 2021 - 14:32 CEST
Identified
Around 75% of consumers attempting to purchase with Term Loan are affected in the US. Our engineering teams have been alerted and are actively investigating. We will update you as soon as we have more information.
Posted Jun 16, 2021 - 12:44 CEST