Credit Card Transactions are failing due to third-party payment provider experiencing issues in the EU
Incident Report for Klarna
Resolved
This incident has been resolved.
Posted Nov 27, 2021 - 10:48 CET
Investigating
3% of credit card transactions are failing due to a third-party payment provider issue. We are contacting the third-party payment provider and monitoring the system.
Posted Nov 27, 2021 - 03:56 CET