Delayed GBP payouts for merchants
Incident Report for Klarna
Resolved
This incident has been resolved.
Posted Nov 06, 2020 - 16:32 CET
Identified
Merchants who receive payouts in British pound sterling will experience a one day delay to their payouts. This is due to an identified technical problem which is currently being remediated. We apologise for the delay and thank you for your patience.
Posted Nov 05, 2020 - 16:17 CET