Issues with opening disputes in the merchant disputes app
Incident Report for Klarna
Resolved
This incident has been resolved.
Posted Jun 16, 2021 - 11:48 CEST
Investigating
This is affecting US, EU, and Australian merchants. We are currently working on a fix.
Posted Jun 16, 2021 - 10:47 CEST