Consumers using ABN AMRO bank in the Netherlands are unable to initiate direct bank transfers through the iDEAL platform
Incident Report for Klarna
Resolved
This incident has been resolved.
Posted Jun 17, 2021 - 08:54 CEST
Investigating
This incident is due to ABN AMRO service unavailability. We are currently investigating the issue. More information available on the iDEAL availability page: https://availability.ideal.nl/
Posted Jun 17, 2021 - 07:37 CEST