Longer waiting times when calling German support lines
Incident Report for Klarna
Resolved
Calls can be received and processed as intended. We apologize for any inconveniences.
Posted Nov 15, 2019 - 11:29 CET
Update
Phone calls should be delivered without further disturbances. Our partner is still investigating the incident's origins.
Posted Nov 08, 2019 - 16:18 CET
Investigating
Customers in Germany are currently experiencing longer waiting times when calling our support lines. This due to a service outage with one of our partner firms. We apologies for the inconvenience this causes. We will provide further updates as soon as possible.
Posted Nov 08, 2019 - 14:33 CET