Customer support service degradation
Incident Report for Klarna
Resolved
This incident has been resolved.
Posted Jul 09, 2022 - 14:27 CEST
Investigating
We are currently experiencing issues with reaching support via phone in North America. Please use mail/chat as an alternative to reach us for support. We are working to restore the service as soon as possible. Thank you for your patience.
Posted Jul 09, 2022 - 05:54 CEST
This incident affected: Support (North America).