Some Order Updates Not Shown
Incident Report for Klarna
Resolved
This incident is now resolved.
Posted 13 days ago. Oct 02, 2019 - 14:04 CEST
Investigating
Customers in Europe and the US will not see any updates to orders made prior to 14:00 CET today. We are working to solve the issue and apologise for the inconvenience caused.
Posted 14 days ago. Oct 01, 2019 - 16:08 CEST
This incident affected: Klarna App.