Users in All regions are not able to see their delivery details on the Klarna App & Web
Incident Report for Klarna
Resolved
This incident has been resolved.
Posted Sep 22, 2021 - 12:34 CEST
Investigating
The issue has been identified and a fix is being deployed.
Posted Sep 22, 2021 - 12:29 CEST