We are currently seeing issues with receiving customer address information from around 24 merchants in the EU region
Incident Report for Klarna
Resolved
This incident has been resolved.
Posted Oct 07, 2021 - 15:48 CEST
Investigating
Our engineering teams are currently investigating the issue.
Posted Oct 07, 2021 - 15:34 CEST
This incident affected: Klarna Payments (KP).