Payment method Pay Now in the EU has degradation since 10:44 p.m. CEST for less than 1% of the consumers using this payment method.
Incident Report for Klarna
Resolved
This incident has been resolved.
Posted May 25, 2021 - 10:50 CEST
Investigating
We are currently investigating this issue.
Posted May 25, 2021 - 10:44 CEST
This incident affected: Klarna Payments (KP).