Personal Finance features in the Klarna app are currently unavailable.
Incident Report for Klarna
Resolved
We've just received the confirmation, this incident is now resolved.
Posted Nov 25, 2019 - 18:27 CET
Investigating
Personal Finance features in the Klarna app are currently unavailable. This includes the ability to connect your bank account as well as viewing balances, statistics and transactions for already connected accounts
Posted Nov 25, 2019 - 17:34 CET
This incident affected: Klarna App.