Issue with processing order management requests
Incident Report for Klarna
Resolved
The issue is resolved. We are back to normal operation.
Posted 9 days ago. Aug 12, 2019 - 14:20 CEST
Investigating
We are currently having issue with processing some of the order management requests. Our engineering team is working on the issue. We are sorry about the inconvenient.
Posted 9 days ago. Aug 12, 2019 - 13:58 CEST
This incident affected: BillPay.