Delayed payouts for UK merchants
Incident Report for Klarna
Resolved
The payments were successfully processed and sent earlier today.
Posted Oct 08, 2020 - 16:33 CEST
Update
We have just gotten more information that payments from yesterday will go out tomorrow as we said previously but payments for today will go out on time and all upcoming payments will not be delayed. We will provide more information tomorrow when payments has gone out or when we have more information.
Posted Oct 07, 2020 - 17:46 CEST
Update
Due to technical difficulties, yesterdays and today's payments will go out tomorrow(8th Oct 2020) morning.
Posted Oct 07, 2020 - 12:41 CEST
Identified
Some merchants in the UK are currently experiencing a delay for their payouts that were executed via BACS payments on Tuesday 2020-10-07. We are working on the issue and will provide an update shortly. We apologize for the inconvenience caused.
Posted Oct 07, 2020 - 10:00 CEST